Jump to content

Recommended Posts

ryankat84    0

I have a 2017 Ri217 with only 14 hours the quick surf left does not engage. It will eventually start working but takes a lot attempts for it to engage. I was wondering if anyone has any tips or tricks to get it to work. It almost seems like a glitch in the system not communicating with the actuator. 

Share this post


Link to post
Share on other sites
InfinitySurf    214

Assume you have shut down system fully with battery off to reset? Its possible it needs software update, but hard to know something like that without more detail. Actuator may have gotten water in it, etc. Under warranty correct

Share this post


Link to post
Share on other sites
wheels    147

The latest software update does have a fix for the surf tabs not retracting all the way but don’t think it will fix it not engaging. I think you have a bad actuator 

Share this post


Link to post
Share on other sites
luluzer    52

I had this exact problem also iin my 217. Turned out the actuator was stripped and wouldn't fully retract. Once I got a new one installed (under the warranty) hasn't happened since. Maybe this is your issue as well?

Share this post


Link to post
Share on other sites
ryankat84    0

Everything seems to be working after I turned off all the power to the entire boat.  I think it is a software issue but for now it is working.  Thanks for the tips.  

Share this post


Link to post
Share on other sites
InfinitySurf    214

software update is pretty easy and painless to do. I asked dealer for a copy on my own USB key (use brand new one) so I will have it if needed in future.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.