Jump to content

marsh9man

Crew
  • Content count

    38
  • Joined

  • Last visited

Community Reputation

0 Neutral

About marsh9man

  • Rank
    Fresh Fish
  • Birthday 06/09/1970

Contact Methods

  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Spokane, Wa

Previous Fields

  • Boat
    Centurion Elite

Recent Profile Visitors

1,464 profile views
  1. Just wanted to follow up in case this helps someone else. After also replacing plugs, wires and MAP sensor, I finally fixed the problem by replacing the Throttle Position Sensor.
  2. Thanks in advance for any help! 2004 centurion elite 350 with 800 hours that I've had for 15 years. Boat starts and idles fine, but bogs down when I accelerate until about 2,000 RPM's and then jumps up to acceleration. It will sometimes stall if I return to idle, but start again fine. I can hear a pump prime when I turn the key. End of season last year it was idling erratically and a little high and stalling when returning to idle from acceleration with an occasional surge when cruising. Since then I have: New cap and rotor New fuel filters (both) Drained old gas and replaced with new gas and sea foam. New IA muffler and IAC valve. Wondering if maybe it's a pump or sensor issue? Any suggestions for further troubleshooting?
  3. But please post back if you find one or with what find out. I wouldn't mind one for my 2004 Elite.
  4. True...but I have to list my 2004 lightning to the point of questioning the safety of it to get a decent wave. (I probably wouldn't worry if I had an Avalanche or an Enzo, or any newer model) We spend our summer on a lake that can be unpredictable the majority of the time. If this would allow me to distribute weight a little more evenly and feel safer while still getting a decent wave, then I feel its' worth trying.
  5. Came across this in my search for more info.....https://www.mastercraft.com/teamtalk/showthread.php?t=70442 Looks goofy, but if it works and only costs 60.00 to make, I may give it a try.
  6. Thanks...I'll give it a try.
  7. Do you know if these pulleys would also fit the 350 mag on a 2004 lightning? Thanks
  8. I am adding tower lights and just got this switch. I am trying to figure out how to wire it and looking for some help. The furthest I have got is that pin 2 would have the main power to it, and pin 1 and 3 would toggle power to either front or rear lights??? Where would ground go? And anything that should be jumped to other pins?? Thanks for any input!
  9. Anyone know the belt/part# for an exact fit for the 350. Mine is pretty worn and not sure if eyeballing it will come close enough. Thanks.
  10. SURF GATE

    http://www.centurioncrew.com/index.php/topic/6767-finally-surfgate-on-my-enzo-sv230/?hl=tuneman
  11. SURF GATE

    Very helpful....thanks. Thinking my best option is to go with a design that I can add/remove each time so I can experiment a little while my boat is moored. Maybe a modification of what Tuneman came up with for his enzo.
  12. SURF GATE

    Thanks for the reply. Did you arrive at any ideal dimensions and/or angle for the surfgate when you were experimenting?
  13. SURF GATE

    Looking forward to any updates on these projects going into the new season...especially those of you working on the old lighting hull.(I have a 2004) I want to add a surf gate this spring, but only have a one shot to get it right since I keep my boat in the water all season. Any and all details (measurements, materials, methods, etc.) would be greatly appreciated. Thanks!
  14. Thanks for the reply. I was just confused by the fact that the belt rides fine on every pulley but the crank. There is room on the shaft to move the pulley some, so I will try that. Is there any way to know when the pulleys are actually aligned other than trial and error?
×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy..