Jump to content

bigbaulla

Crew
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bigbaulla

  • Rank
    Newbie
  • Birthday 04/21/1975

Contact Methods

  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Oklahoma City

Previous Fields

  • Boat
    Centurion Cyclone

Recent Profile Visitors

198 profile views
  1. I changed the inline fuel filter and the issue has been resolved. Thank you all for your suggestions!
  2. Does anyone know what the PSI for the fuel system should be reading under normal conditions?
  3. It only occurs at higher speeds / rpm's. When it gets around 30 mph it acts like I've put the throttle in neutral. It sputters, backfires/misfires and tries to recover but never can. Runs fine at idle and up to that point. I've replaced all the spark plugs as well.
  4. Hi all, I have a 2007 Cyclone with the 5.7 L Black Scorpion. I'm experiencing a loss of power at speeds above 30 mph. The engine will backfire / misfire and slow way down but doesn't die. I put in neutral and can accelerate again but will repeat at anything above 30 mph. It starts and idles fine and will run great at speeds below 25. I have replaced the distributor cap, rotor, plugs, water / fuel separator. Connected a fuel pressure gauge at the valve on top of the engine and it read 20 psi at turn key. Started the engine and it read about 30 psi. I know there are 2 fuel pumps but I can't determine if this is the issue and if so which one might be bad. Any ideas of what might be going on? Thank you for any help!
  5. I changed the spark plugs and made the stupid mistake of removing the wires on top of the distributor cap to check the nodes underneath and didn't label the wires. Now the boat idles rough and when I put it in gear it tries to almost backfire. Don't know if I have the wires out of order or if its an issue with the NGK plugs I put in. Also does the distributor cap have to go on a certain way. I don't remember how it was oriented over the rotor. Ughhh
  6. I have a 5.7L Black Scorpion. Would anyone know where cylinder 1 is located? Port or Starboard side? Front or back of the engine? Thanks.
×

Important Information

By using this site, you agree to our Terms of Use.