Jump to content

04cyclonev

Crew
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About 04cyclonev

  • Rank
    Newbie

Profile Information

  • Gender
    Male

Previous Fields

  • Boat
    Centurion Eclipse
  1. I agree man, I used to own an older ski nautique and on their forums they are super helpful with the older boats. I have gotten zero input here except from you... ill check out the pump your talking about and get underneath and check out all the possible areas for water intrusion. thanks so much
  2. no ideas? any help would be appreciated.
  3. Hello all, I am a first time poster here, i have been reading for a while and have an issue I've been noticing for a while now with my 2004 Eclipse V drive. The boat stays on trailer our climate controlled warehouse when its not being used, lately I have noticed that it will have a slow drip from the t handle hull drain for at least a week maybe more after it has been used. the walk thru cooler is used and stocked with ice every time we use the boat. both the t handle and the rear plug are pulled at the ramp when we are done using the boat but still once we get back to warehouse it continues to drip. the hose on the port side of the engine with the hose flush port stays full... that was my first though that it was in fact leaking somewhere. I just checked it tonight after 8 days of it being out of the water and it has one drip every 30-40 seconds, I have not gotten my head into it yet but wanted to ask the pros on here before I did. any help would be appreciated thanks
×

Important Information

By using this site, you agree to our Terms of Use.