Jump to content

Search the Community

Showing results for tags 'touchscreen'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Feedback, Announcements and Crew Deals
    • Site Announcements
    • Site Feedback & Support
    • Crew Deals
  • CenturionCrew.Com
    • Centurion Boats General Discussion
    • Centurion Boat Accessories, Electronics and Modifications
    • Centurion Boat Maintenance, Performance, Troubleshooting
    • News From Centurion Boats and Dealers!
    • Centurion Boat Owners Hook-Up
  • SupremeCrew.Com
    • Supreme Boats General Discussion
    • Supreme Boat Accessories, Electronics and Modifications
    • Supreme Boat Maintenance, Performance, Troubleshooting
    • News From Supreme Boats and Dealers!
  • General Discussions
    • Watersports & Related Gear
    • Marine Audio
    • Articles by Members
    • Off Topic
    • Boat Shows, Local Events and Gatherings

Marker Groups

  • Members
  • Centurion Boat Dealers
  • Centurion Boats/Fineline Industries

Calendars

There are no results to display.

Categories

  • Boats
  • Gear

Found 3 results

  1. 2013 centurion enzo sv230. The lower 1/4 of my touchscreen no longer responds to touch input. I can't empty my pro port ballasts or turn on cruise control as a result. I was hoping there was some recalibration I could do, but I can't figure out how to get into dealer settings. I know the code is "91" but I can't figure out where to provide the code. How do I get to a screen where I can provide the code to enter dealer settings? I tried turning on the ignition while holding one of the 4 buttons next to the touchscreen, but it just says "Booting..." forever and never boots.
  2. 2013 SV23 Enzo. The ignition button does not power the touchscreen. Battery seems to be OK because blower works, radio works. Dials go through initial startup when I turn the key on. However, when i push the ignition button - no screen and the engine won't start. I assume engine won't start if screen does not initialize? I'm assuming a fuse or a breaker? Not sure if boats have breakers. Can someone point me to the fuse/breaker for the touchscreen?
  3. I'm having to power down and restart multiple times a day because the touch screen just goes crazy pushing random buttons, filling and draining ballasts, changing speed, etc... I'm able to fix it by powering off and restarting, but I have to do it multiple times a day. Anyone else have this issue and know if it's a bad screen or a simple fix? 2014 Enzo SV244 with only 110 hours
×

Important Information

By using this site, you agree to our Terms of Use.