Jump to content

Search the Community

Showing results for tags 'paddle'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Feedback, Announcements and Crew Deals
    • Site Announcements
    • Site Feedback & Support
    • Crew Deals
  • CenturionCrew.Com
    • Centurion Boats General Discussion
    • Centurion Boat Accessories, Electronics and Modifications
    • Centurion Boat Maintenance, Performance, Troubleshooting
    • News From Centurion Boats and Dealers!
    • Centurion Boat Owners Hook-Up
  • SupremeCrew.Com
    • Supreme Boats General Discussion
    • Supreme Boat Accessories, Electronics and Modifications
    • Supreme Boat Maintenance, Performance, Troubleshooting
    • News From Supreme Boats and Dealers!
  • General Discussions
    • Watersports & Related Gear
    • Marine Audio
    • Articles by Members
    • Off Topic
    • Boat Shows, Local Events and Gatherings

Marker Groups

  • Members
  • Centurion Boat Dealers
  • Centurion Boats/Fineline Industries

Calendars

There are no results to display.

Categories

  • Boats
  • Gear

Found 1 result

  1. Took my new-to-me 05 Centurion Elite C4 on its maiden voyage today. Everything all good except I have no speedo and the steeringwheel (rudder) seems to be 90 deg off to the port side (pulls starboard when positioned straight). I guess my question is, what are some things or logical steps to troubleshoot speedo now that its in my driveway AND can a guy align the rudder and wheel pretty easily? I'm no stranger to the wrenches, just looking for some "check this first" advice before I get to tearing into it, I'd like to get back on the lake fully working ASAP! Thanks in advance! (originally posted in general, but realized post belonged here)
×

Important Information

By using this site, you agree to our Terms of Use.