Jump to content

Search the Community

Showing results for tags '2008'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Feedback, Announcements and Crew Deals
    • Site Announcements
    • Site Feedback & Support
    • Crew Deals
  • CenturionCrew.Com
    • Centurion Boats General Discussion
    • Centurion Boat Accessories, Electronics and Modifications
    • Centurion Boat Maintenance, Performance, Troubleshooting
    • News From Centurion Boats and Dealers!
    • Centurion Boat Owners Hook-Up
  • SupremeCrew.Com
    • Supreme Boats General Discussion
    • Supreme Boat Accessories, Electronics and Modifications
    • Supreme Boat Maintenance, Performance, Troubleshooting
    • News From Supreme Boats and Dealers!
  • General Discussions
    • Watersports & Related Gear
    • Marine Audio
    • Articles by Members
    • Off Topic
    • Boat Shows, Local Events and Gatherings

Marker Groups

  • Members
  • Centurion Boat Dealers
  • Centurion Boats/Fineline Industries

Calendars

There are no results to display.

Categories

  • Boats
  • Gear

Found 2 results

  1. I need help from anyone that has tried this or has any ideas. I have a 2008 Centurion Enzo. I actually haven't even put it in the water yet but I had to put the tower down to get it in my garage. I will have to do this every time I put the boat away to fit in my lift. It seems as if I have to unscrew completely four knobs to allow the tower to fold. I know from experience that this is an accident waiting to happen and one of those knobs is going to be dropped and sink to the bottom of the river. Has anyone done any modifications for a quick release set up? I doubt it is possible since the holes are threaded and I don't want anything rattling while moving but I figured this would be the best place to ask. I will post pictures as soon as the boat is on the water and cleaned up. Thanks,
  2. Hello, I own a 2008 Enzo SV 220. Recently I have been having an issue with the boat slipping under a load (surfing) or accelerating hard. The engine compartment recently had quite a bit of water in it. We had a big rain storm and for some reason the bilge was not pumping out any water? From looking at posts on this site sounds like I may have water in the transmission oil and/or the Vdrive. Does my boat have a Vdrive and a transmission. The boat is 3 hours away and I need to pick up fluids in the city here. Can some body let me know what transmission oil I need and what fluid for the Vdrive? (Walter). Am I on the right track here. Is this actually my issue? Boat only has 120 hrs. Thanks for responses. Mike
×

Important Information

By using this site, you agree to our Terms of Use.