Jump to content

Recommended Posts

codycuellar    0

Hey crew! After 15 years of filling up 3500lbs of fat sacs and using a wake shaper on my dad’s ‘94 MC Prostar 205, I was finally able to convince him to go in on a new boat with me. We ended up picking up a 2021 Fi23 60hrs for a great price and just got it launched on our lake a few days ago. I have to say, this boat is an absolute dream! I can finally fit my whole family and kids on the boat and not lose 1.5 hrs filling and tearing down the boat! Can’t wait to get a killer surf season out of it this year!

Anyway, so far everything seems to be working great on it except I can’t quite seem to figure out the stereo/accessory system, or the wireless charger phone holder. When I received the boat last fall I recall the charger not working right away but eventually my phone picked it up, but now with my iPhone 13, it doesn’t seem to want to charge, even with the case off. The other issue is the stereo accessory mode. It seems the stereo should work when the key switch is to the left but it doesn’t seem to turn the stereo on. There’s an accessory button to the left but it doesn’t seem to do much either. At one point the music randomly stayed on but we couldn’t figure out how it happened. Perhaps there’s a secret combination of the accessory button and key switch we're missing? Also if the stereo comes on with the ignition turned left, how do you control the volume without the dash? Any tips would be greatly appreciated, thanks!

Share this post


Link to post
Share on other sites
Wylie_Tunes    149

Just a shot here. i just worked on a 2020 Supreme that had a stereo rocker. However, the stereo rocker only had 12V when the key switch was in ACC or RUN. 

Solved this real quick. Wired the stereo rocker's 12V input to a constant 12V under the helm. Took the key switch out of the loop. Stereo stays on regardless of key switch.

Share this post


Link to post
Share on other sites
Troy. R    187
2 hours ago, Wylie_Tunes said:

Just a shot here. i just worked on a 2020 Supreme that had a stereo rocker. However, the stereo rocker only had 12V when the key switch was in ACC or RUN. 

Solved this real quick. Wired the stereo rocker's 12V input to a constant 12V under the helm. Took the key switch out of the loop. Stereo stays on regardless of key switch.

I need to do this, but haven’t got around to it yet.

Share this post


Link to post
Share on other sites
codycuellar    0

What’s odd is that in the manual it shows a switch labeled ‘stereo’. But in the boat it’s just ‘Acc’ and does nothing. Do other peoples boats stereos turn on with that switch or with a left turn on the key ignition? Neither work for us. I’m beginning to think it needs some service.

Share this post


Link to post
Share on other sites
69C10    1
On 2022-05-20 at 7:41 AM, codycuellar said:

What’s odd is that in the manual it shows a switch labeled ‘stereo’. But in the boat it’s just ‘Acc’ and does nothing. Do other peoples boats stereos turn on with that switch or with a left turn on the key ignition? Neither work for us. I’m beginning to think it needs some service.

For 21 centurion and supreme went to the integrated ICE stereo. It doesn’t sound like there’s any easy way around it, just leave the key in the run position for power to the screen and stereo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy..