Jump to content

Recommended Posts

07tacoswb    0

Hello all,

        I'm needing some guidance.  I just recently purchased my first boat.  It's a 2007 Centurion Typhoon C4 with the PCM Excalibur 330 and the PCM vdrive and transmission.  I have a dash light that I believe is for the vdrive.  It will randomly light up.  It's at different RPMs.  Sometimes I will be cruising at 3200rpm and it will be off then on then off again.  Where is the pressure sensor located?  I've tried the upload the pics but having some trouble with the sizing and I can't seem to link it either.  Thanks for any help.

Share this post


Link to post
Share on other sites
Troy    222

My Walter V-drive is on the starboard side. Check the wire connections. They corrode. 

Share this post


Link to post
Share on other sites
07tacoswb    0

I may have stated the v-drive info wrong.  It's a Pleasurecraft Power Plus.  Any idea where the sensor would be on this?  Also anyone have info on the oil type and level?  Thanks for all the help.

Share this post


Link to post
Share on other sites
volzalum    262

I do not believe the Pleasurecraft V-Drive has the dash light.

Share this post


Link to post
Share on other sites
07tacoswb    0

Huh.  Well there is a light on my dash between the tach and speedo and it will cycle on and off depending on the RPM's.  What could it be?  I've checked all fluids except for the V-Drive.  I'm going to check that tonight.  The guy I bought the boat from kept all service records and kept the boat in excellent shape.  I'm not noticing any unusual noises.  Thanks for the help. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.