Jump to content

Recommended Posts

We have a 2016 S238 that has been working great until today. We were out wakesurfing and sudden we lost power and the service required message appeared on the display along with a beeping alarm.. When this happend we could not get up over 7mph no matter how much throttle. I shut the ignition off and turnef off the main power switch for about 5m. I then turned the power switch on and started the engine and no service required alarm was displaying any longer and we were able to throttle up like normal and wakesurf for snother 30m or so until we suddenly had the engine completely stop/shut off but with no codes or snything showing on the display. I tried to restart the boat and it turned over like normal but would not fire up/start at all after many attempts. I suspected the engine was not getting fuel as I could not hear the fuel pump run and pressurize like normal when the ignition was turned to on prior to turning fully to start. I checked the fuses and sure enough one of the fuel pump fuses was blown. I replaced the fuse and it started right up and i could hear the fuel pump run when ignition switched  on prior to starting. .I thought all was well and we surfed for abour 2hr when the service required warming and beeping alarm came on again and we could not accelerate above 7mph again. Does anyone have any ideas or advice as to why this issue with the fuel pump is occurring and what I can do to rectifyi the problem? Thanks in advance!!

Share this post


Link to post
Share on other sites

Sounds like fuel pump might be bad, or could be shorted out wire rubbing on block. Check the harness.

Share this post


Link to post
Share on other sites
rrd525    39

I posted a similar issue last month on our 2016 S238.

A dealer advised to check all fuses, and especially the main fuse there and harness.
We also swapped our water/fuel filter out again after 20 hours of use, and changed the FCC filter.
We always use premium fuel to reduce ethanol content, and use Stabil during winter storage.

*****
Our boat has been reliable, but yesterday threw us for a loop.
Wouldn't get fuel and keep running.
Initially we thought vapour lock but that wasn't it.
Tried the main fuse, batteries off for a reset.
No fuel pump prime noise. Eventually find the fuse panel under the engine cover. There we found the 20amp fuel pump fuse blown and burnt.

Easy, swap it with a new one. Wrong. I have 6 of every fuse size, but not in mini.

Luckily we keep wire, ends and tools onboard and we hobbled together a fix to keep us surfing for the day.

Needless to say we now picked up mini and maxi fuses to add to the arsenal.
Still at a loss as to why the fuse failed.
******

37249606_1696407277142569_8295757468554756096_n.jpg

37206048_1696407347142562_6504906816525172736_n.jpg

37225256_1696407243809239_8851105316977246208_n.jpg

37226446_1696407193809244_4845242684966699008_n.jpg

37244611_1696407397142557_4377763364839882752_n.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.