Jump to content

Recommended Posts

ljcooljc    0

hello new to the forum so forgive me in advance

 i have a 2002 centurion hurricane with the 350 Mag MPI Tow Sports s/n OM310293. yesterday on the water the serpentine belt slipped off, i was able to salvage part of the belt to get back to the dock thank goodness. at first i thought the idler pulley must have a bad bearing, so went home to order parts and this is where the trouble started. when i look up parts for the serpentine belt and a replacement pulley i get conflicting part numbers. (807757T idler pulley 3" diameter) or (864625T idler pulley 4.25") same with the serpentine belt i get (8638765 serpentine belt 87.5") and (807755 serpentine belt 88")

what puzzles me is the sizes... is it universal because of the idler pulley bracket has an adjustment? 

i called a local shop and when they look it up same thing... please help id like to get back out on the water :))))

Share this post


Link to post
Share on other sites
InfinitySurf    200
11 minutes ago, ljcooljc said:

hello new to the forum so forgive me in advance

 i have a 2002 centurion hurricane with the 350 Mag MPI Tow Sports s/n OM310293. yesterday on the water the serpentine belt slipped off, i was able to salvage part of the belt to get back to the dock thank goodness. at first i thought the idler pulley must have a bad bearing, so went home to order parts and this is where the trouble started. when i look up parts for the serpentine belt and a replacement pulley i get conflicting part numbers. (807757T idler pulley 3" diameter) or (864625T idler pulley 4.25") same with the serpentine belt i get (8638765 serpentine belt 87.5") and (807755 serpentine belt 88")

what puzzles me is the sizes... is it universal because of the idler pulley bracket has an adjustment? 

i called a local shop and when they look it up same thing... please help id like to get back out on the water :))))

Call Skidim in SC, I get my parts from them (they are also online, very helpful and know their stuff). Bakes is also good and someone you could call, but seems like (to me anyway) Skidim may have more parts. Sure there are other places as well with parts that can help you to source what you need and verify part numbers.

Skidim has a couple 10% off discount codes...There may be one for this forum, but I know that "MALIBU" works as I used it last week when I ordered some stuff from them.

Share this post


Link to post
Share on other sites
woodman4    1
3 hours ago, ljcooljc said:

hello new to the forum so forgive me in advance

 i have a 2002 centurion hurricane with the 350 Mag MPI Tow Sports s/n OM310293. yesterday on the water the serpentine belt slipped off, i was able to salvage part of the belt to get back to the dock thank goodness. at first i thought the idler pulley must have a bad bearing, so went home to order parts and this is where the trouble started. when i look up parts for the serpentine belt and a replacement pulley i get conflicting part numbers. (807757T idler pulley 3" diameter) or (864625T idler pulley 4.25") same with the serpentine belt i get (8638765 serpentine belt 87.5") and (807755 serpentine belt 88")

what puzzles me is the sizes... is it universal because of the idler pulley bracket has an adjustment? 

i called a local shop and when they look it up same thing... please help id like to get back out on the water :))))

When I look it up using your serial number I see it as part number 807757T for the idler puller. The other part number you listed is the tensioner pulley.

I just replaced the tensioner pulley on mine which happens to be the same part number as your idler pulley, and I just took the old one to NAPA and they were able to find me a replacement by looking up pulleys for trucks that use the same engine.

 

Here is what I used to look up parts

https://www.marineengine.com/parts/mercury_marine_parts/sn/0M310293/33500089S/8184_20

Share this post


Link to post
Share on other sites
ljcooljc    0

Thank you very much guys. I appreciate all of you. What ended up happening is when the boat was last serviced they switched the idler pulley and the tensioner pulley locations so there wasn't proper tension on the belt. 

Thank you very much for all your help. I really appreciate the input. It took forever for me to figure it out. But now we are up and ready to go :))

Share this post


Link to post
Share on other sites
woodman4    1
5 hours ago, ljcooljc said:

Thank you very much guys. I appreciate all of you. What ended up happening is when the boat was last serviced they switched the idler pulley and the tensioner pulley locations so there wasn't proper tension on the belt. 

Thank you very much for all your help. I really appreciate the input. It took forever for me to figure it out. But now we are up and ready to go :))

I’d be staying far away from that place in the future!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.